cancelar
Mostrando resultados para 
Pesquisar então 
Você quer dizer: 
  • ×
    Informação
    Windows 11

    Saiba como atualizar para o Windows 11 usando o Windows Update, confira aqui

    Encontre perguntas e respostas comuns aquí.

    Informação
    Corrija erros no Windows 10

    Resolva os problemas de atualização do Windows 10 em um PC HP – Centro de suporte HP para Windows 10

  • post a message
  • ×
    Informação
    Windows 11

    Saiba como atualizar para o Windows 11 usando o Windows Update, confira aqui

    Encontre perguntas e respostas comuns aquí.

    Informação
    Corrija erros no Windows 10

    Resolva os problemas de atualização do Windows 10 em um PC HP – Centro de suporte HP para Windows 10

  • post a message
Nota para problemas comuns em Notebooks
Se você está com problemas na WEBCAM em seu Notebook, confira o tópico: Dica - Erro 0xA00F4244 Webcam / HP Truevision como Solucionar .
Estudante Top
Estudante Top
2 1 1 0
Mensagem 1 de 2
420 Exibições
Reportar Mensagem

Solucionado!

14-v064br não comunica mais com windows CE após atualização windows10 jul/17

hp 14-v064br
Microsoft Windows 10 (64-bit)

Já usava o windows10 no meu 14-v064br há muito tempo. Entretanto, ao fazer as atualizações de segurança do W10 (jun/17), o Windows Mobile Device Center deixou de funcionar. Aparentemente, alguma alteração de driver está causando o problema. Fiz de tudo, incluindo uma reinstalação do Windows, que provou que até o windows 8.1(isso porque não consegui a versão do w10 anteriror à atualização) tudo funciona bem. Basta atualizar (nesse caso agora fazer o upgrade) e volta-se a ter o problema. O detalhe é que tenho outro notebook DELL que recebeu a mesma atualização,  e lá o Windows mobile funcionou normalmente. Preciso do software funcionando para fazer a comunicação com um GPS que tenho e que tem instalado o Windows CE 5. Algúem tem alguma ideia do que possa ser. Obrigado

1 SOLUÇÃO ACEITA

Soluções aceitas
Estudante Top
Autor
Estudante Top
2 1 1 0
Mensagem 2 de 2
Reportar Mensagem

Solucionado!

14-v064br não comunica mais com windows CE após atualização windows10 jul/17

Consegui a solução do problema consutando o forum HP EUA. 

Abaixo a solução elaborada pelo Alexander.

 

"Change an user account, which is used to start "Windows Mobile-2003-based device connectivity" Service (WcesComm). Originally the "Local Service" is used. After changing to "Local System" I could start this service and the Motorola device has started to connect to the pc.

The only problem is now - it connects only once. After disconnecting and connecting I have to restart "Windows Mobile-2003-based device connectivity" and "Windows Mobile-2003-based device connectivity".

Looks like, the "Local Service" account's permissions have been changed in the creator update and the WcessComm cannot create a semaphore (permission denied)."

Alexander


"Hi

So, after some debugging and searching the problem seems to be solved even with Local Service account.
The creators update has a new feature, related to svchost.exe: the services will not share by default the same svchost.exe, even they are assigned to be run within of the same group with -k option. More detailed has been described here.

Rapimgr and Wcescomm (Windows Mobile-based device connectivity and Windows Mobile-2003-based device connectivity) are such services: they are defined to be started in the same shared svchost.exe (-k WindowsMobile). RapiMgr creates a kernel semaphore AS_ACCEPTANCE_SEMA, because it starts first. WcesComm tries to do this too, but fails: the semaphore has been already created and should be only opened. This will fail: not enough permissions (remember: two different svchost.exe, different SID, etc). So, wcescomm is just stopped.

The fix is simply: add SvcHostSplitDisable to the both services RapiMgr and WcesComm:
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
Both services should have the same Local Service Account. You have to reboot after this change.

Added: Both services should have on Recovery tab in "Subsequent failures" the "Restart Service" enabled. Seems, RapiMgr crashes sometimes on the device disconnecting."

Exibir solução no post original

Essa resposta foi útil? Sim Não
1 RESPONDER 1
Estudante Top
Autor
Estudante Top
2 1 1 0
Mensagem 2 de 2
Reportar Mensagem

Solucionado!

14-v064br não comunica mais com windows CE após atualização windows10 jul/17

Consegui a solução do problema consutando o forum HP EUA. 

Abaixo a solução elaborada pelo Alexander.

 

"Change an user account, which is used to start "Windows Mobile-2003-based device connectivity" Service (WcesComm). Originally the "Local Service" is used. After changing to "Local System" I could start this service and the Motorola device has started to connect to the pc.

The only problem is now - it connects only once. After disconnecting and connecting I have to restart "Windows Mobile-2003-based device connectivity" and "Windows Mobile-2003-based device connectivity".

Looks like, the "Local Service" account's permissions have been changed in the creator update and the WcessComm cannot create a semaphore (permission denied)."

Alexander


"Hi

So, after some debugging and searching the problem seems to be solved even with Local Service account.
The creators update has a new feature, related to svchost.exe: the services will not share by default the same svchost.exe, even they are assigned to be run within of the same group with -k option. More detailed has been described here.

Rapimgr and Wcescomm (Windows Mobile-based device connectivity and Windows Mobile-2003-based device connectivity) are such services: they are defined to be started in the same shared svchost.exe (-k WindowsMobile). RapiMgr creates a kernel semaphore AS_ACCEPTANCE_SEMA, because it starts first. WcesComm tries to do this too, but fails: the semaphore has been already created and should be only opened. This will fail: not enough permissions (remember: two different svchost.exe, different SID, etc). So, wcescomm is just stopped.

The fix is simply: add SvcHostSplitDisable to the both services RapiMgr and WcesComm:
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
Both services should have the same Local Service Account. You have to reboot after this change.

Added: Both services should have on Recovery tab in "Subsequent failures" the "Restart Service" enabled. Seems, RapiMgr crashes sometimes on the device disconnecting."

Exibir solução no post original

Essa resposta foi útil? Sim Não
Nota para problemas comuns em Notebooks
Se você está com problemas na WEBCAM em seu Notebook, confira o tópico: Dica - Erro 0xA00F4244 Webcam / HP Truevision como Solucionar .
† As opiniões expressas acima são de responsabilidade exclusiva de seus autores, e não da HP. Utilizar este site significa aceitar os termos de uso e as Regras de Participação